Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sound config
09-29-2011, 05:32 PM
Post: #1
Sound config
Call me stupid, but I don't remember how to configure the soundcard (ac 97).
Maybe it's a good sign, it means that I don't have to configure/install Delicate very often :]

Hardware in use: Compaq PIII- 1GHZ, Geforce 4000, 256mb, 80gb HD
Dutch Delicate Linux information: http://www.delicatelinux.nl.ae
Visit this user's website Find all posts by this user
Quote this message in a reply
09-30-2011, 09:24 AM (This post was last modified: 09-30-2011 09:30 AM by tavvva.)
Post: #2
RE: Sound config
No ... You're not stupid ... this is still a dark area of DeLi(cate).
Our sndconfig is way too old and was intended to be used for older legacy soundcards only, because they often need additional parameters and it's difficult to guess their available ranges.

You can try to load the following module manually as root ...

modprobe i810_audio

then check the logs / test the sound / etc.

If that's ok, then define the module either in the modules.conf or in the rc.modules ...

But .... please, provide me with Your lspci -vv output -> I'd like to patch the sndconfig tool in order to make it support this soundcard.

Btw. it seems You've installed DeLi(cate) on something newer than Pentium II, right? That's not a typical hardware for DeLi(cate) Big Grin
Visit this user's website Find all posts by this user
Quote this message in a reply
09-30-2011, 11:46 AM
Post: #3
RE: Sound config
Thank you, it works :]
The lspci -vv output:

Code:
00:00.0 Host bridge: Intel Corporation 82810E DC-133 (GMCH) Graphics Memory Controller Hub (rev 03)
    Subsystem: Intel Corporation 82810E DC-133 (GMCH) Graphics Memory Controller Hub
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
    Latency: 0

00:01.0 VGA compatible controller: Intel Corporation 82810E DC-133 (CGC) Chipset Graphics Controller (rev 03) (prog-if 00 [VGA controller])
    Subsystem: Giga-byte Technology Device 0200
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at dc000000 (32-bit, prefetchable) [size=64M]
    Region 1: Memory at ee000000 (32-bit, non-prefetchable) [size=512K]
    Capabilities: <access denied>

00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02) (prog-if 00 [Normal decode])
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
    I/O behind bridge: 0000c000-0000cfff
    Memory behind bridge: e3e00000-ebefffff
    Prefetchable memory behind bridge: dbc00000-dbcfffff
    Secondary status: 66MHz- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
    BridgeCtl: Parity- SERR+ NoISA- VGA- MAbort- >Reset- FastB2B-
        PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
    Kernel modules: shpchp, pciehp, i810_rng, hw_random

00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
    Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0

00:1f.1 IDE interface: Intel Corporation 82801AA IDE Controller (rev 02) (prog-if 80 [Master])
    Subsystem: Intel Corporation 82801AA IDE Controller
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Region 4: I/O ports at ff00 [size=16]

00:1f.2 USB Controller: Intel Corporation 82801AA USB Controller (rev 02) (prog-if 00 [UHCI])
    Subsystem: Intel Corporation 82801AA USB Controller
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin D routed to IRQ 9
    Region 4: I/O ports at da00 [size=32]
    Kernel modules: usb-uhci, uhci

00:1f.3 SMBus: Intel Corporation 82801AA SMBus Controller (rev 02)
    Subsystem: Intel Corporation 82801AA SMBus Controller
    Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Interrupt: pin B routed to IRQ 10
    Region 4: I/O ports at 04c0 [size=16]

00:1f.5 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 02)
    Subsystem: Giga-byte Technology Device 2000
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin B routed to IRQ 10
    Region 0: I/O ports at de00 [size=256]
    Region 1: I/O ports at dc00 [size=64]
    Kernel modules: i810_audio

01:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    Subsystem: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 64 (8000ns min, 16000ns max)
    Interrupt: pin A routed to IRQ 11
    Region 0: I/O ports at cc00 [size=256]
    Region 1: Memory at e8000000 (32-bit, non-prefetchable) [size=256]
    Expansion ROM at ebef0000 [disabled] [size=64K]
    Capabilities: <access denied>
    Kernel modules: 8139too, 8139cp

01:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    Subsystem: Unex Technology Corp. ND010/ND012
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 64 (8000ns min, 16000ns max)
    Interrupt: pin A routed to IRQ 10
    Region 0: I/O ports at c800 [size=256]
    Region 1: Memory at e6000000 (32-bit, non-prefetchable) [size=256]
    Capabilities: <access denied>
    Kernel modules: 8139too, 8139cp

There are 2 network adapters plugged in (I don't know why, after all this pc was a free one). Maybe it's not a typical Delicate machine, but the other alternative (catching dust in a dark place) would be a waste..

Hardware in use: Compaq PIII- 1GHZ, Geforce 4000, 256mb, 80gb HD
Dutch Delicate Linux information: http://www.delicatelinux.nl.ae
Visit this user's website Find all posts by this user
Quote this message in a reply
10-01-2011, 08:01 PM
Post: #4
RE: Sound config
(09-30-2011 11:46 AM)nl2stk Wrote:  There are 2 network adapters plugged in (I don't know why, after all this pc was a free one).

Older computers are often used as home or small company routers .... that's why there are 2 network adapters .... internal and external interface ....

Since DeLi(cate) has iptables, it can be used as router with DeLi(cate) too :]
Visit this user's website Find all posts by this user
Quote this message in a reply
11-07-2011, 04:21 PM (This post was last modified: 11-07-2011 07:08 PM by tavvva.)
Post: #5
RE: Sound config
Please, test the latest release of the sndconfig tool.
I made several changes to the tool. It should support several variations of the AC'97 Audio now. Some of the AC'97 variations might be NOT fully compatible and I'd like to have some feedback which of them work well and which of them do not.
Some of the cards might have listed a missing snd-intel8x0 module whilst they could work with the i810_audio module. I would like to get some feedback in such cases.

In some cases You might hear the voice slowed down (low-tone). If so, then try to pass the clocking=44100 or clocking=48000 option to the i810_audio module:

/etc/modprobe.conf

alias sound-slot-0 i810_audio
options sound-slot-0 clocking=48000
Visit this user's website Find all posts by this user
Quote this message in a reply
11-08-2011, 02:11 PM
Post: #6
RE: Sound config
(11-07-2011 04:21 PM)tavvva Wrote:  Some of the cards might have listed a missing snd-intel8x0 module whilst they could work with the i810_audio module. I would like to get some feedback in such cases.

Tonight (if I'm feeling well) I'll give it a shot.

Hardware in use: Compaq PIII- 1GHZ, Geforce 4000, 256mb, 80gb HD
Dutch Delicate Linux information: http://www.delicatelinux.nl.ae
Visit this user's website Find all posts by this user
Quote this message in a reply
11-08-2011, 02:49 PM (This post was last modified: 11-08-2011 02:50 PM by tavvva.)
Post: #7
RE: Sound config
(11-08-2011 02:11 PM)nl2stk Wrote:  
(11-07-2011 04:21 PM)tavvva Wrote:  Some of the cards might have listed a missing snd-intel8x0 module whilst they could work with the i810_audio module. I would like to get some feedback in such cases.

Tonight (if I'm feeling well) I'll give it a shot.

Ok :] Don't forget to discard any manual changes You made in the past in order to make it work ... then reboot the computer and test, that You really have NO SOUND, before trying to run the sndconfig tool.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-14-2011, 01:52 PM (This post was last modified: 11-14-2011 08:40 PM by tavvva.)
Post: #8
RE: Sound config
(11-08-2011 02:49 PM)tavvva Wrote:  Ok :] Don't forget to discard any manual changes You made in the past in order to make it work ... then reboot the computer and test, that You really have NO SOUND, before trying to run the sndconfig tool.

Strange, but it seems that I can't update.
Several messages that the software on my computer seems to be newer Huh
Perhaps it's wiser to replace my updated Deli with the official Delicate.

Hardware in use: Compaq PIII- 1GHZ, Geforce 4000, 256mb, 80gb HD
Dutch Delicate Linux information: http://www.delicatelinux.nl.ae
Visit this user's website Find all posts by this user
Quote this message in a reply
11-14-2011, 08:39 PM (This post was last modified: 11-14-2011 08:40 PM by tavvva.)
Post: #9
RE: Sound config
(11-14-2011 01:52 PM)nl2stk Wrote:  
(11-08-2011 02:49 PM)tavvva Wrote:  Ok :] Don't forget to discard any manual changes You made in the past in order to make it work ... then reboot the computer and test, that You really have NO SOUND, before trying to run the sndconfig tool.

Strange, but it seems that I can't update.
Several messages that the software on my computer seems to be newer Huh
Perhaps it's wiser to replace my updated Deli with the official Delicate.

Could You please copy&paste the messages?
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | DeLi(cate) Linux | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication