Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation on Laptop Acer Extensa 355
03-13-2015, 09:43 PM
Post: #1
Installation on Laptop Acer Extensa 355
Hello Delicate users.

I try install delicate Linux latest release alpha5! on a laptop from acer called Extensa 355.
I have 20GB harddrive on this.

So what do I have:
Machine is Pentium MMX 150MHz
RAM: 16 MB
A Floppydrive
ATA Harddrive can only see it in BIOS as 8034MB. (Even harddrive is bigger)
There is Parallel Port and Serial Port and PCMCIA. (2 but think one is defective) I try networkcard it finds the Card on Win98SE. (3com)

There is No CD Rom drive.

I have installed: Windows 98 Second Edition and is running.
I have installed LILO and can get it run with the installer, but.

The problem is I can choose from CD and Serial I use CD type in to my FAT32 partition for my delicate installation files latest release alpha5!

Layout is the following:
hda1 (BOOT - WINDOWS98) FAT32 2048MB
1 GB free space
hda5 (Linux native) ext3 /boot only 64MB which is suggest!

hda3 (Extended primary) ext3 and / 12GB
hda4 (ext3) swap for Linux 192MB
hda6 (HELPME Files) FAT32 4GB

I can then run install.bat if i say f8 and run command only my Lilo files for delicate is on c drive or hda1.

I type /dev/hda6 when ask for files the files on CD is copy to HELPME or D: but it doesn't do it correctly on install.

I found out that /target/ for hda3 should be root! and boot files should if possibly be on hda5 /boot area is inside of target which looks correct.

When I install all looks fine but when boot from DOS Again using Lilo or delicate.bat file it does not give me login prompt or type username, since I have made a password for root and another user.

So I guess I miss some setup on some files in /etc like inittab, fstab or other files passwd. (Can someone with a working alpha5 give output on these files how the look inside)

As far I know there is no files for LILO on delicate alpha5 iso it looks like GRUB is this a problem?
Find all posts by this user
Quote this message in a reply
03-14-2015, 12:00 PM (This post was last modified: 03-14-2015 12:02 PM by tavvva.)
Post: #2
RE: Installation on Laptop Acer Extensa 355
(03-13-2015 09:43 PM)TTD Wrote:  Hello Delicate users.


Hello :]

(03-13-2015 09:43 PM)TTD Wrote:  I try install delicate Linux latest release alpha5! on a laptop from acer called Extensa 355.
I have 20GB harddrive on this.

So what do I have:
Machine is Pentium MMX 150MHz
RAM: 16 MB
A Floppydrive
ATA Harddrive can only see it in BIOS as 8034MB. (Even harddrive is bigger)


That is quite common for BIOSes without the LBA support. In your case the number of heads is limited to 255 (some BIOSes support 256) and with 1024 cylinders and 63 sectors it gives 1024*255*63*512 = 8422686720 B = 8225280 KiB = 8032,5 MiB. Hard to guess why the result is miscalculated as 8034 :] The 256 heads variant goes up to 8064 MiB.

(03-13-2015 09:43 PM)TTD Wrote:  There is Parallel Port and Serial Port and PCMCIA. (2 but think one is defective) I try networkcard it finds the Card on Win98SE. (3com)

There is No CD Rom drive.

I have installed: Windows 98 Second Edition and is running.
I have installed LILO and can get it run with the installer, but.


Are you sure you're writing about LILO and not about LOADLIN?
These are two different products. If you start the Linux from DOS,
then you mean LOADLIN.

(03-13-2015 09:43 PM)TTD Wrote:  The problem is I can choose from CD and Serial I use CD type in to my FAT32 partition for my delicate installation files latest release alpha5!

Layout is the following:
hda1 (BOOT - WINDOWS98) FAT32 2048MB
1 GB free space
hda5 (Linux native) ext3 /boot only 64MB which is suggest!

hda3 (Extended primary) ext3 and / 12GB
hda4 (ext3) swap for Linux 192MB
hda6 (HELPME Files) FAT32 4GB

I can then run install.bat if i say f8 and run command only my Lilo files for delicate is on c drive or hda1.

I type /dev/hda6 when ask for files the files on CD is copy to HELPME or D: but it doesn't do it correctly on install.

I found out that /target/ for hda3 should be root! and boot files should if possibly be on hda5 /boot area is inside of target which looks correct.

When I install all looks fine but when boot from DOS Again using Lilo or delicate.bat file it does not give me login prompt or type username, since I have made a password for root and another user.

So I guess I miss some setup on some files in /etc like inittab, fstab or other files passwd. (Can someone with a working alpha5 give output on these files how the look inside)

As far I know there is no files for LILO on delicate alpha5 iso it looks like GRUB is this a problem?

Well. From the lines above I'm not sure whether you described all the steps correctly. The alpha5 CD installs GRUB -and/or- LOADLIN. The LILO loader is still present on the CD as installable package, but it is not installed by default. It can only be installed manually from the installer shell or from the installed system.
If you're installing the system from FAT/FAT32, the installer should be able to find the installation files if they are all correctly copied to the root directory of the FAT/FAT32 filesystem. The LOADLIN config then asks you where to put the LOADLIN files + kernel and if you don't want to boot with GRUB, then you don't need the /boot mountpoint at all and you can skip the GRUB installation. I'd like to see the content of your delicate.bat and I'd like to know whether you believe all the packages were installed correctly.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-14-2015, 06:15 PM
Post: #3
RE: Installation on Laptop Acer Extensa 355
(03-14-2015 12:00 PM)tavvva Wrote:  
(03-13-2015 09:43 PM)TTD Wrote:  Hello Delicate users.


Hello :]

(03-13-2015 09:43 PM)TTD Wrote:  I try install delicate Linux latest release alpha5! on a laptop from acer called Extensa 355.
I have 20GB harddrive on this.

So what do I have:
Machine is Pentium MMX 150MHz
RAM: 16 MB
A Floppydrive
ATA Harddrive can only see it in BIOS as 8034MB. (Even harddrive is bigger)


That is quite common for BIOSes without the LBA support. In your case the number of heads is limited to 255 (some BIOSes support 256) and with 1024 cylinders and 63 sectors it gives 1024*255*63*512 = 8422686720 B = 8225280 KiB = 8032,5 MiB. Hard to guess why the result is miscalculated as 8034 :] The 256 heads variant goes up to 8064 MiB.

Yes I did remember the numbers wrong, therefore the miscalc. Smile

(03-13-2015 09:43 PM)TTD Wrote:  There is Parallel Port and Serial Port and PCMCIA. (2 but think one is defective) I try networkcard it finds the Card on Win98SE. (3com)

There is No CD Rom drive.

I have installed: Windows 98 Second Edition and is running.
I have installed LILO and can get it run with the installer, but.


Are you sure you're writing about LILO and not about LOADLIN?
These are two different products. If you start the Linux from DOS,
then you mean LOADLIN.

(03-13-2015 09:43 PM)TTD Wrote:  The problem is I can choose from CD and Serial I use CD type in to my FAT32 partition for my delicate installation files latest release alpha5!

Layout is the following:
hda1 (BOOT - WINDOWS98) FAT32 2048MB
1 GB free space
hda5 (Linux native) ext3 /boot only 64MB which is suggest!

hda3 (Extended primary) ext3 and / 12GB
hda4 (ext3) swap for Linux 192MB
hda6 (HELPME Files) FAT32 4GB

I can then run install.bat if i say f8 and run command only my Lilo files for delicate is on c drive or hda1.

I type /dev/hda6 when ask for files the files on CD is copy to HELPME or D: but it doesn't do it correctly on install.

I found out that /target/ for hda3 should be root! and boot files should if possibly be on hda5 /boot area is inside of target which looks correct.

When I install all looks fine but when boot from DOS Again using Lilo or delicate.bat file it does not give me login prompt or type username, since I have made a password for root and another user.

So I guess I miss some setup on some files in /etc like inittab, fstab or other files passwd. (Can someone with a working alpha5 give output on these files how the look inside)

As far I know there is no files for LILO on delicate alpha5 iso it looks like GRUB is this a problem?

Well. From the lines above I'm not sure whether you described all the
steps correctly. The alpha5 CD installs GRUB -and/or- LOADLIN. The LILO loader is still present on the CD as installable package, but it is not installed by default. It can only be installed manually from the installer shell or from the installed system.
If you're installing the system from FAT/FAT32, the installer should be able to find the installation files if they are all correctly copied to the root directory of the FAT/FAT32 filesystem. The LOADLIN config then asks you where to put the LOADLIN files + kernel and if you don't want to boot with GRUB, then you don't need the /boot mountpoint at all and you can skip the GRUB installation. I'd like to see the content of your delicate.bat and I'd like to know whether you believe all the packages were installed correctly.

The main problem for me at first was I couldn't install grub at all.
Some progress for me, the grub have been installed on the mbr at this moment, so skipped the .bat file and loadlin.

The problem for me now is, how can I made it possible to boot to the old Windows 98, I had.

I have reinstall all again, think I did some wrong, but the best practices for me, is to choose tar base files then goto another window and manually use the tar -zxvf feature and install every packages, because some of the files fails, or not working correctly, even this is taken from the .iso file image.

I will look on the bat file again if I can enter my old Windows 98 again. Smile

Maybe there come more maybe abou how do I install my modules correctly, so it will startup everytime and not after I use insmod. Wink
Find all posts by this user
Quote this message in a reply
03-18-2015, 12:47 AM (This post was last modified: 03-18-2015 12:49 AM by tavvva.)
Post: #4
RE: Installation on Laptop Acer Extensa 355
(03-14-2015 06:15 PM)TTD Wrote:  The main problem for me at first was I couldn't install grub at all.
Some progress for me, the grub have been installed on the mbr at this moment, so skipped the .bat file and loadlin.

The problem for me now is, how can I made it possible to boot to the old Windows 98, I had.

The DOS/Win autodetection is not ready yet. You need to add the entry manually from the installed linux. Just add the following three lines to the /boot/grub/menu.lst file and you should have your DOS/Win back.

title Windows
root (hd0,0)
chainloader +1


(03-14-2015 06:15 PM)TTD Wrote:  I have reinstall all again, think I did some wrong, but the best practices for me, is to choose tar base files then goto another window and manually use the tar -zxvf feature and install every packages, because some of the files fails, or not working correctly, even this is taken from the .iso file image.

Mmmmm, this is really strange and you will very probably end up with pretty messed system. Are you sure your harddrive works well? Did you activate the swap partition prior installing? Is the ISO file downloaded correctly? Have you checked the MD5 sum?

(03-14-2015 06:15 PM)TTD Wrote:  I will look on the bat file again if I can enter my old Windows 98 again. Smile

Maybe there come more maybe abou how do I install my modules correctly, so it will startup everytime and not after I use insmod. Wink

What modules do you mean? The delisetup executed from the root account should do the work for you in most cases.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | DeLi(cate) Linux | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication