Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
printing with cups issues
07-04-2014, 07:36 PM
Post: #1
printing with cups issues
Hello,

First of all, thank you for the availability of this distribution for the old machines. It allowed me to revive my old AMD 5x86 PC (the one which is an overclocked 4x86).

The issue is that I cannot get it to print from the standard office apps. I installed cups, the cups service is enabled through delisetup, the printer was set up through the web-interface (localhost:631).

The setup is made to print through an ipp port to another Fedora 9 linux machine in the network. I can print test pages through the web-interface.

But I cannot see the printer neither in ABIWord, nor in GNUmeric, Leafpad or GIMP.
A "generic postscript printer" and a "Create a PDF document" are the only choices in ABI Word, and in other applications - Print to File or Print to Printer. When I print to a printer (which points me to lpr port), the applications crash.

What am I doing wrong?

Regards.
Find all posts by this user
Quote this message in a reply
07-05-2014, 03:29 PM
Post: #2
RE: printing with cups issues
(07-04-2014 07:36 PM)krz Wrote:  Hello,

First of all, thank you for the availability of this distribution for the old machines. It allowed me to revive my old AMD 5x86 PC (the one which is an overclocked 4x86).

Hello. Nice to read that!


(07-04-2014 07:36 PM)krz Wrote:  The issue is that I cannot get it to print from the standard office apps. I installed cups, the cups service is enabled through delisetup, the printer was set up through the web-interface (localhost:631).

The setup is made to print through an ipp port to another Fedora 9 linux machine in the network. I can print test pages through the web-interface.

But I cannot see the printer neither in ABIWord, nor in GNUmeric, Leafpad or GIMP.
A "generic postscript printer" and a "Create a PDF document" are the only choices in ABI Word, and in other applications - Print to File or Print to Printer. When I print to a printer (which points me to lpr port), the applications crash.

What am I doing wrong?

You're the first user, who ever tried to print from DeLi(cate) and gave us a feedback. It's probably a bug that needs to be solved.
Please, let me do few tests here first and stay tuned.
Thanks.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-07-2014, 12:49 PM
Post: #3
RE: printing with cups issues
Will be waiting to hearing from you...

deli hardware: AMD 5x86 @150 MHz; 64 Mb FPM RAM; 4.0 Gb HDD; ATI Rage IIc PCI 4Mb + 15" Samtron TFT.
Find all posts by this user
Quote this message in a reply
07-07-2014, 08:38 PM
Post: #4
RE: printing with cups issues
(07-07-2014 12:49 PM)krz Wrote:  Will be waiting to hearing from you...

The root cause lies in the gtk2 component. There are 2 issues:
It fails to build with the cups support and needs fixes ...
It pulls the whole ghostscript with the cups and gtk2 stealing 50MB of space :/ I'm thinking about making this optional and available via a separate repository.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-08-2014, 09:03 AM
Post: #5
RE: printing with cups issues
Hi,

Thank you for this research. It would be nice if I could print from this machine.

Regards.

deli hardware: AMD 5x86 @150 MHz; 64 Mb FPM RAM; 4.0 Gb HDD; ATI Rage IIc PCI 4Mb + 15" Samtron TFT.
Find all posts by this user
Quote this message in a reply
07-25-2014, 09:40 AM
Post: #6
RE: printing with cups issues
Hi,

Maybe I could print with the current features? Maybe some settings with CUPS on the server side for I could print with lpr protocol?

Regards.

deli hardware: AMD 5x86 @150 MHz; 64 Mb FPM RAM; 4.0 Gb HDD; ATI Rage IIc PCI 4Mb + 15" Samtron TFT.
Find all posts by this user
Quote this message in a reply
07-25-2014, 05:55 PM
Post: #7
RE: printing with cups issues
(07-25-2014 09:40 AM)krz Wrote:  Hi,

Maybe I could print with the current features? Maybe some settings with CUPS on the server side for I could print with lpr protocol?

Regards.

Hi. Sorry, I'm still trying to find a solution. Please, stay tuned :]
Visit this user's website Find all posts by this user
Quote this message in a reply
08-10-2014, 11:55 PM (This post was last modified: 08-10-2014 11:57 PM by tavvva.)
Post: #8
RE: printing with cups issues
I fixed the gtk-cups issue and rebuilding the relevant components. Please upgrade your system to the latest version of all components and try again.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-11-2014, 12:21 PM (This post was last modified: 08-11-2014 12:23 PM by tavvva.)
Post: #9
RE: printing with cups issues
I finally know what was wrong in your case. You forgot to set the printer as default. Abiword doesn't crash, but it is terminated when you have no default printer set and print with lpr without specifying the own custom command as lpr -Pprintername where printername is the name of the cups printer.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-13-2014, 05:35 PM
Post: #10
RE: printing with cups issues
Thanks! Will test it.

deli hardware: AMD 5x86 @150 MHz; 64 Mb FPM RAM; 4.0 Gb HDD; ATI Rage IIc PCI 4Mb + 15" Samtron TFT.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | DeLi(cate) Linux | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication