Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
inheritated shared library problem
01-07-2012, 04:28 PM (This post was last modified: 01-07-2012 04:29 PM by delix.)
Post: #1
inheritated shared library problem
from my pervious attempts to getJava running with DeLi, I still get the warning message :

Code:
ldconfig : can't read header from /usr/lib/libgtk_webcore_jscore-0.5.3.so.1.0.0
ldconfig : can't read header from /usr/lib/libgtk_webcore_jscore-0.5.3.so.1
the first file exists but with 0 kb size.
What must I do to get rid of the message ? Must I add another package or remove something ?
Find all posts by this user
Quote this message in a reply
01-07-2012, 06:54 PM
Post: #2
RE: inheritated shared library problem
(01-07-2012 04:28 PM)delix Wrote:  from my pervious attempts to getJava running with DeLi, I still get the warning message :

Code:
ldconfig : can't read header from /usr/lib/libgtk_webcore_jscore-0.5.3.so.1.0.0
ldconfig : can't read header from /usr/lib/libgtk_webcore_jscore-0.5.3.so.1
the first file exists but with 0 kb size.
What must I do to get rid of the message ? Must I add another package or remove something ?

Maybe You would like to start from the beginning and tell us the whole story? :]
Visit this user's website Find all posts by this user
Quote this message in a reply
01-07-2012, 08:33 PM
Post: #3
RE: inheritated shared library problem
a looong loong time ago I tried to get a application written in Java running on DeLi. So I tried to build a JRE for DeLi 0.8 and compiled a package for it (I guess I can remember it was kaffe).
Long story short -- I never was able to handle the JRE due to my lack of any experience with Java. As it should be just a preview on the app, I didn't spend more time on the JRE at all, so please don't ask anything about it. All I did was to take the PKGBUILD file from ARCH and run makepkg .......

For any reason I cannot remember I deleted some files manually and not with the pacman -R command. Later on it used it, but obviously some links (or something else) were broken already.

So these seem to be remainings from a JRE or I deleted some files I shouldn't.....
(maybe parts of GTK ?)

So do you have any idea how I can getout of this mess? Well, I can't see any other effect than the warnings by now -- but who knows, what I've done......
Find all posts by this user
Quote this message in a reply
01-08-2012, 12:15 AM (This post was last modified: 01-08-2012 12:16 AM by tavvva.)
Post: #4
RE: inheritated shared library problem
(01-07-2012 08:33 PM)delix Wrote:  a looong loong time ago I tried to get a application written in Java running on DeLi. So I tried to build a JRE for DeLi 0.8 and compiled a package for it (I guess I can remember it was kaffe).
Long story short -- I never was able to handle the JRE due to my lack of any experience with Java. As it should be just a preview on the app, I didn't spend more time on the JRE at all, so please don't ask anything about it. All I did was to take the PKGBUILD file from ARCH and run makepkg .......

For any reason I cannot remember I deleted some files manually and not with the pacman -R command. Later on it used it, but obviously some links (or something else) were broken already.

So these seem to be remainings from a JRE or I deleted some files I shouldn't.....
(maybe parts of GTK ?)

So do you have any idea how I can getout of this mess? Well, I can't see any other effect than the warnings by now -- but who knows, what I've done......

The mentioned file seems to be a part of the gtk-webcore-jscore package. AFAIK it was never a part of the DeLi 0.8 or DeLi(cate) ... It's a Javascript interpreter for gtk-webcore and has nothing to do with Java. It could possibly be one of the dependencies You tried to build in order to make the whole thing work. And the 0k file must be some junk from Your builds :] The only way is to remove all the junk You've produced during Your Java related experiments and that could be quite difficult if You are unsure about the junk origin :]
Visit this user's website Find all posts by this user
Quote this message in a reply
01-08-2012, 03:42 PM
Post: #5
RE: inheritated shared library problem
well, as it stems not from a DeLi-package, I deleted the files.
The warning is gone and by now I no unwanted effect turns up...

Thx for the hints, tavvva
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us | DeLi(cate) Linux | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication