DeLi(cate) Forum
Very old laptop - need some help :) - Printable Version

+- DeLi(cate) Forum (http://delicate-linux.net/forum)
+-- Forum: DeLi(cate) Linux [english only] (/forumdisplay.php?fid=3)
+--- Forum: Support (/forumdisplay.php?fid=27)
+--- Thread: Very old laptop - need some help :) (/showthread.php?tid=199)

Pages: 1 2 3 4 5 6 7 8


RE: Very old laptop - need some help :) - nl2stk - 02-17-2012 10:53 AM

A while ago I've made a PKGBUILD for xmahjongg. I couldn't test it because it needed 1024 x 768, so I was missing a bit. I can post it in the pkgbuild section, perhaps someone can test it?


RE: Very old laptop - need some help :) - tavvva - 02-17-2012 12:59 PM

(02-17-2012 10:16 AM)euronet Wrote:  I got 1 question here , if I write a multisession cd for these packages ( dont want to burn many cds or dont want to wait too long )
is the system able to read this multisession cd ?

thanks

It depends more on the CD drive. Sometimes the burner's ray power calibration differs from the power calibration used during burning of the previous session and such difference sometimes lead to drive's inability of reading the new sessions.


RE: Very old laptop - need some help :) - tavvva - 02-17-2012 09:55 PM

(02-17-2012 10:53 AM)nl2stk Wrote:  A while ago I've made a PKGBUILD for xmahjongg. I couldn't test it because it needed 1024 x 768, so I was missing a bit. I can post it in the pkgbuild section, perhaps someone can test it?

Oh ... I remember that Big Grin but I was able to use Alt+mouse+mousebutton to move with the window to the left and to the right until I got rid of the most outer tiles Big Grin
I could eventually patch it to work with 800x600 displays


RE: Very old laptop - need some help :) - euronet - 02-18-2012 01:25 AM

ace of penguins + ninvaders = installed now I will try to run them , osmo too
syasokoban I got this msg : error: unsatisfied dependencies : syasokoban: requires sdl

edit : ace of penguins installed, I can see all games included. I cant see ninvaders ... idk where is it Smile
osmo works fine too took some time to load but then it was ok


RE: Very old laptop - need some help :) - nl2stk - 02-18-2012 11:55 AM

(02-17-2012 09:55 PM)tavvva Wrote:  
(02-17-2012 10:53 AM)nl2stk Wrote:  A while ago I've made a PKGBUILD for xmahjongg. I couldn't test it because it needed 1024 x 768, so I was missing a bit. I can post it in the pkgbuild section, perhaps someone can test it?

Oh ... I remember that Big Grin but I was able to use Alt+mouse+mousebutton to move with the window to the left and to the right until I got rid of the most outer tiles Big Grin
I could eventually patch it to work with 800x600 displays

This is what I have :].
It was made before the menu-generator was planned, so a few things are missing (icons, desktop entry). I believe it's compatible with the tilesets from Kyodai (a wellknown Mahjongg game for windows).

Code:
# Maintainer:
# Thanks to: Eric BĂ©langer

pkgname=xmahjongg
pkgver=3.7
pkgrel=1
pkgdesc="Mahjongg game for X-Window"
url="http://www.lcdf.org/xmahjongg/"
license=('GPL')
depends=('gcc' 'libX11')
source=(http://www.lcdf.org/${pkgname}/${pkgname}-${pkgver}.tar.gz)
md5sums=('9db5bf1b329b410220b7976cd9b3d374')

build() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  ./configure --prefix=/usr --mandir=/usr/share/man --host=$CHOST --build=$CHOST
  make || return 1
  make DESTDIR="${pkgdir}" install
}

An 800x600 version would be very nice..


RE: Very old laptop - need some help :) - tavvva - 02-18-2012 05:09 PM

(02-18-2012 01:25 AM)euronet Wrote:  ace of penguins + ninvaders = installed now I will try to run them , osmo too
syasokoban I got this msg : error: unsatisfied dependencies : syasokoban: requires sdl

Haven't I told you to download all packages at once? Big Grin

(02-18-2012 01:25 AM)euronet Wrote:  edit : ace of penguins installed, I can see all games included. I cant see ninvaders ... idk where is it Smile
osmo works fine too took some time to load but then it was ok

ninvaders are still waiting for being rebuilt to support our menu generator ... but you can start the game from the terminal or do it in console :]


RE: Very old laptop - need some help :) - nl2stk - 02-18-2012 05:32 PM

(02-18-2012 05:09 PM)tavvva Wrote:  [quote='euronet' pid='1076' dateline='1329524755']
ace of penguins + ninvaders = installed now I will try to run them , osmo too
syasokoban I got this msg : error: unsatisfied dependencies : syasokoban: requires sdl

tavvva Wrote:Haven't I told you to download all packages at once? Big Grin

This is a good example that sometimes you need a bit more than just the package :]
syasokoban (and other games too) needs the SDL dependencies, b.t.w. it's not a 'linux' thing since SDL is available for windows too.


RE: Very old laptop - need some help :) - euronet - 02-19-2012 12:55 PM

a) xmahjongg.tar.gz = downloade it and trying to install but I get : missing package info file

b) syasokoban I got this msg : error: unsatisfied dependencies : syasokoban: requires sdl

tavvva Wrote:
Haven't I told you to download all packages at once?

I dloaded sdl pkg installed it and then installed syasokoban , works fine Smile ( as I said 1 step each time )

c) I runned ninvaders from console (xterm) game opened still remaining to find control keys Tongue

thanks again


RE: Very old laptop - need some help :) - nl2stk - 02-19-2012 02:58 PM

(02-19-2012 12:55 PM)euronet Wrote:  c) I runned ninvaders from console (xterm) game opened still remaining to find control keys Tongue

thanks again

Space to start the game and shoot, they other keys are the left/right cursorkeys :]


RE: Very old laptop - need some help :) - euronet - 02-19-2012 03:37 PM

Space to start the game = works
and shoot, they other keys are the left/right cursorkeys = not working