DeLi(cate) Forum

Full Version: Pacman gives an error on system upgrade
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I am reinstalling Delicate on a laptop. The install from cdrom goes fine until I try to upgrade packages over the network with pacman. The first time I issue "pacman -Syu", pacman upgrades itself without problems, but the next time I issue "pacman -Suy" to upgrade the rest of the packages, I get the following error. Huh

Code:
pacman -Syu
:: Synchronizing package databases...
main                     [################] 100%    1050K   109.2K/s  00:00:09

Targets: abiword-2.4.6-6 atk-1.9.1-12 bc-1.06-6 bitlbee-1.0.4-2 bzip2-1.0.4-3
         cairo-1.2.4-5 curl-7.18.1-2 delitools-0.8.1.15-1 expat-2.0.1-3
         fontconfig-2.5.0-2 freetype2-2.3.5-3 gettext-0.16.1-7 glib2-2.12.13-5
         gtk2-2.10.14-6 kernel-ide-2.4.37.11-8 libX11-1.1.3-2 libfontenc-1.0.4-2
         libice-1.0.4-2 libiconv-1.10-4 libidl-0.8.7-2 libjpeg-6b-5
         libpng-1.2.8-5 libsm-1.0.3-2 gcc-libs-3.4.6-3 libtiff-3.8.2-4
         libxau-1.0.3-2 libxcursor-1.1.9-3 libxdmcp-1.0.2-2 libxext-1.0.4-2
         libxfixes-4.0.3-2 libxfont-1.3.2-2 libxfontcache-1.0.4-2 libxi-1.1.3-2
         libxmu-1.0.4-2 libxp-1.0.0-2 libxrandr-1.2.2-2 libxrender-0.9.4-2
         libxt-1.0.5-2 libxxf86misc-1.0.1-2 libxxf86vm-1.0.1-2
         menu-generator-0.6-4 ncurses-5.6-7 openssl-1.0.0.d-3 libxft-2.1.12-1
         pango-1.14.10-4 readline-5.2-6 slim-1.3.2-7 intltool-0.50.2-1
         transmission-1.80-1 uclibc-0.9.28-6 xclients-7.2-3 xz-5.0.0-3
         zlib-1.2.3-5

Total Package Size:   33.5 MB

Proceed with upgrade? [Y/n]
:: Retrieving packages from main...
libxxf86misc-1.0.1-2     [################] 100%       5K     8.8K/s  00:00:00
libxxf86vm-1.0.1-2       [################] 100%       7K    13.0K/s  00:00:00

checking package integrity... done.
loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
  gcc-libs: /usr/lib/libgcc_s.so.1: exists in filesystem
  gcc-libs: /usr/lib/libstdc++.so.6: exists in filesystem
  gcc-libs: /usr/lib/libstdc++.so.6.0.3: exists in filesystem

errors occurred, no packages were upgraded.

The two packages that downloaded before the error message happened (libxxf86misc-1.0.1-2 and libxxf86vm-1.0.1-2) don't seem to have anything to do with the error. This is because when I tried pacman -Syu again, three completely different packages downloaded before the same error message ocurred.

I also got exactly the same error message when I tried to upgrade Delicate that was already installed on a different computer. According to /var/log/pacman.log, I last upgraded this other install of Delicate on 2012-10-01.

I don't see this error mentioned in the forums, so I'm wondering if this error has something to do with upgrading a long neglected (or brand new!) install of Delicate?
Hello :]

I was waiting for the very first report of that. The issue is related to the currently ongoing splitting of all packages to main and devel. Please, update delitools and temporarily enable the main-devel repository. The problem is caused mainly by the gcc, pkgconfig and libraries depending on *proto packages.
This is going to be fixed soon.
I just decided to move gcc and pkgconfig back to the main repo until the splitting is done ... so .... try that again without enabling the main-devel repository ....
(03-06-2013 01:28 PM)tavvva Wrote: [ -> ]I just decided to move gcc and pkgconfig back to the main repo until the splitting is done ... so .... try that again without enabling the main-devel repository ....

Hi Tavvva,

Thanks, that worked just fine. Big Grin I was surprised that a new install of Delicate would result in such an error--not very inviting for people trying it out the first time.Sad
Reference URL's