DeLi(cate) Forum

Full Version: menu-generator 0.1 in the repo
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I just uploaded a very first release of the menu generator. This version supports icewm only.

The generator can be activated by the following line marked with bold put in the .xinitrc file:

...
menu-generator-daemon icewm
exec icewm-session

---------------

.desktop files and icons are still missing -> use it only for testing purposes until the mass rebuild is finished
It doesn't work here, X won't start and the errormessage is:
Waiting for x server to shutdown FreeFontPath: IPE "/usr/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing.
(01-05-2012 05:44 PM)nl2stk Wrote: [ -> ]It doesn't work here, X won't start and the errormessage is:
Waiting for x server to shutdown FreeFontPath: IPE "/usr/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing.

hmmmm .... have You changed the .xinitrc file anyhow? could You please post it here?

The daemon is not finished yet ... it allows multiple instances, etc. But it somehow works in my case.
Does the .icewm directory exist in Your homedir? It doesn't generate anythhing if it's missing, but X should work even if it is missing.
Another question ...

What happens if You remove the line, then start icewm and run menu-generator icewm > ~/.icewm/menu from xterm ? Is the menu regenerated using the available .desktop files?
Yes it does, but it doesn't replace the existing menu or creating a menu file.
(01-05-2012 08:22 PM)nl2stk Wrote: [ -> ]Yes it does, but it doesn't replace the existing menu or creating a menu file.

What is Your username? Who is the ~/.icewm/menu file owner? What are the ~/.icewm/menu file permissions?

Are You doing that from the regular user account?
If You want to see the new icons, then rename the /usr/share/icewm/icons directory to icons.bak and then create a symlink to the pixmap location...

ln -s /usr/share/pixmaps /usr/share/icewm/icons


This symlink will be made permanent with the icewm rebuild, so ... don't forget to put it back once the new release is available.
(01-05-2012 08:41 PM)tavvva Wrote: [ -> ]What is Your username? Who is the ~/.icewm/menu file owner? What are the ~/.icewm/menu file permissions?

Are You doing that from the regular user account?

Everything was fine, my username was theo, and was the owner and I could read and write.
I did it from my normal user account.
But I'am one step further, I backed up my normal ./icewm directory and after that I deleted it and put a clean one in it (from /usr/share/icewm). And after that I gave the command on xterm and it works.
Mysterious? Yes, but I worked Smile

EDIT: it only works from the terminal. With the daemon in .xinitrc I get the same error.
My .xinitrc is 'standard', no conky or rox-pinboard is loaded.
(01-06-2012 10:42 AM)nl2stk Wrote: [ -> ]EDIT: it only works from the terminal. With the daemon in .xinitrc I get the same error.
My .xinitrc is 'standard', no conky or rox-pinboard is loaded.

are You really really sure there's no typo in Your .xinitrc?

Could You please backup Your .xinitrc file and create a new one from the delisetup?

It really works without any signs of problems on all my systems ... and as this is quite critical component right now, I'd like to be sure, that everything works correctly.
Pages: 1 2 3
Reference URL's