DeLi(cate) Forum

Full Version: Microsoft USB Mouse
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've mention a couple of days ago that I've informed the Dutch Ubuntu forum about Delicate, and a couple of users are testing and running it.
One of them is testing it on a P4 with one 1 GB ram with a nvidia geforce fx 5200 and he has a problem, he can't get his mouse working. It's a Microsoft USB mouse, and he has tried the 'Auto' and 'Microsoft' settings. Is there another setting he can try?
(10-31-2011 11:32 PM)nl2stk Wrote: [ -> ]Is there another setting he can try?

I guess he has no USB modules loaded and therefore his USB controller doesn't work.

The following two modules are needed for HID devices in case of UHCI controller:
uhci
hid


The following two modules are needed for HID devices in case of OHCI controller:
usb-ohci
hid


The controler type can be seen in the lspci output.
Modules can be temporarily loaded from the root account by calling modprobe usb-ohci or different module ...

Then the default input device /dev/input/mice should be configured in the xorg setup
and then it finally has any sense to play with the protocol :]

If that works, then the modules need to be defined in the rc.modules like /sbin/modprobe uhci, etc.

If that still doesn't work for him, I would need output of the following two commands:

lspci

and

lsmod

-------------------------

The whole thing should be automated by the scripts one day .... the hardware detection is unfortunately still missing Undecided
Reference URL's